Back to overview
Downtime
Plex Authentication and API Server, Cloudflare CDN/Cache, and 1 other service are down
Oct 20 at 10:26am BST
Affected services
Plex Authentication and API Server
Cloudflare CDN/Cache
Cloudflare Authoritative DNS
Resolved
Oct 20 at 11:14am BST
Plex Authentication and API Server, Cloudflare CDN/Cache, and Cloudflare Authoritative DNS recovered.
Affected services
Created
Oct 20 at 10:26am BST
Plex Authentication and API Server, Cloudflare CDN/Cache, and Cloudflare Authoritative DNS went down.
Affected services